Third party API problem
Incident Report for Seravo
Resolved
This incident has been resolved.
Posted Sep 17, 2023 - 07:13 UTC
Identified
We have noticed a third party API problem which causes some sites being unreachable or responding slow. The problem will be resolved automatically after the problem is fixed.
Posted Sep 17, 2023 - 03:00 UTC
This incident affected: External Services.