Availability issues with sites using external DNS

Incident Report for Seravo

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 21:19 UTC

Investigating

Customers that have opted to use external DNS for their site might encounter availability issues with their sites.
Incident does not affect customers using only Seravo-provided hosting services.
Posted Feb 25, 2026 - 21:14 UTC
This incident affected: External Services.