Degarded performance on sites which use plugins depending on Finnish postal service api
Incident Report for Seravo
Resolved
This incident has been resolved.
Posted Sep 17, 2022 - 23:48 UTC
Identified
Degraded performance in third party service is affecting sites that use plugins which depend Finnish postal service apis.

Plugins affected: posti-shipping
Posted Sep 17, 2022 - 23:08 UTC
This incident affected: External Services.