3rd party nameserver problem
Incident Report for Seravo
Resolved
This incident has been resolved.
Posted Mar 30, 2022 - 18:37 UTC
Identified
We have detected that VM IT nameservers are not responding currently. This is affecting some of our hosted sites.
Posted Mar 30, 2022 - 14:49 UTC
This incident affected: External Services.