Global Crowdstrike incident - Seravo hosting directly unaffected
Incident Report for Seravo
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 17:25 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2024 - 16:15 UTC
Investigating
Currently multiple services online have their performance degraded due to the ongoing Crowdstrike incident.

Seravo hosting however is unaffected by this incident.

However sites dependent on external services, such as nameservers, may affected as those services could be affected by the ongoing incident.
Posted Jul 19, 2024 - 09:50 UTC
This incident affected: External Services.