Availability issues with sites using external DNS

Incident Report for Seravo

Resolved

This incident has been resolved.
Posted Jun 15, 2026 - 19:25 UTC

Monitoring

Customers that have opted to use external DNS ( dns{1..4}triuvare-webhosting.fi) for their site might encounter availability issues with their sites. Incident does not affect customers using only Seravo-provided hosting services.
Posted Jun 15, 2026 - 13:36 UTC
This incident affected: External Services.