Active DDoS campaign
Incident Report for Seravo
Resolved
This incident has been resolved.
Posted May 04, 2024 - 19:58 UTC
Identified
We are under an active DDoS campaign and we are mitigating the issue. All the data is safe. If the campaign is related to a specific domain or web site, we are in contact with the customer in question separately.
Posted May 03, 2024 - 07:31 UTC
This incident affected: Finland (fi-sestak cluster).