Mail delivery from WordPress sites not working currently
Incident Report for Seravo
Resolved
This incident has been resolved.
Posted Mar 11, 2024 - 16:23 UTC
Identified
WordPress mail delivery is still down due to a problem with SendGrid. We are actively resolving the issue with the service provider. We apologize for the inconvenience.
Posted Mar 11, 2024 - 08:49 UTC
Investigating
We are currently investigating this issue.
Posted Mar 07, 2024 - 15:50 UTC
This incident affected: WordPress E-Mail Delivery via SendGrid.