Customer support phone line is down
Incident Report for Seravo
Resolved
This incident has been resolved.
Posted Jun 10, 2024 - 08:02 UTC
Identified
The cause of the phone line outage has been identified, and a fix is being implemented.
Posted Jun 10, 2024 - 07:26 UTC
Update
We are continuing to investigate this issue.
Posted Jun 10, 2024 - 07:06 UTC
Investigating
The phone line for customer support is currently down, and the fault is currently under investigation. We apologize for the inconvenience – you can always contact us by chat or email, help@seravo.com.
Posted Jun 10, 2024 - 07:06 UTC
This incident affected: Customer Support Phone Line.