3rd party nameserver problem
Incident Report for Seravo
Resolved
Incident seems to be resolved.

Nebula's status message regarding to the incident:
https://www.inmicsnebula.fi/fi/tiedotteet/dns-palveluissa-hairio
Posted Mar 02, 2022 - 10:32 UTC
Identified
We have detected that Nebula nameservers are not responding currently. This is affecting some of our hosted sites.
Posted Mar 02, 2022 - 09:56 UTC
This incident affected: External Services.