Mail delivery from WordPress sites not working currently
Incident Report for Seravo
Resolved
This incident has been resolved.
Posted Feb 12, 2024 - 12:47 UTC
Update
We are doing our best to sort this out with the service provider.
Posted Feb 12, 2024 - 12:06 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 11, 2024 - 15:03 UTC
Investigating
We have noticed an issue with mail delivery from the WordPress sites and are currently investigating the cause and working on a fix for it.
Posted Feb 11, 2024 - 14:38 UTC
This incident affected: WordPress E-Mail Delivery via SendGrid.