Third party API failures causing site issues

Incident Report for Seravo

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 18:59 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2026 - 17:36 UTC

Update

The problem is related to Meta API services that slow down the sites. The sites will remain to work normally after the issue is fixed by the service provider.
Posted Mar 05, 2026 - 16:24 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 05, 2026 - 16:01 UTC

Identified

We identified an upstream service provider networking issue causing slowness on some sites. We apologise for any inconvenience.
Posted Mar 05, 2026 - 15:08 UTC
This incident affected: Finland (fi-coltrane cluster, fi-ellington cluster, fi-haarla cluster, fi-perko cluster, fi-rantala cluster, fi-sestak cluster, fi-tolonen cluster, fi-lahti cluster, fi-fredriksson cluster).