Clouldflare related availability issues

Incident Report for Seravo

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 18:34 UTC

Update

Cloudflare has updated status on the incident:

https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 11:51 UTC

Investigating

Some sites using Cloudflare are experiencing issues and have degraded availability.

We're investigating further, but issue seems to be external.
Posted Nov 18, 2025 - 11:45 UTC
This incident affected: External Services.