Issue with Gandi email services

Incident Report for Seravo

Resolved

This incident has been resolved.
Posted 25 days ago. Mar 11, 2025 - 07:08 UTC

Identified

There is issue ongoing with Gandi email services. More information: https://status.gandi.net/
Posted 26 days ago. Mar 10, 2025 - 05:47 UTC
This incident affected: External Services.