Twitter API problems
Incident Report for Seravo
Resolved
This incident has been resolved.
Posted Mar 28, 2022 - 13:46 UTC
Investigating
We noticed that Twitter API suffers from slowness and intermittent outages that may cause some error messages or slowness on sites using Twitter feed plugins.
Posted Mar 28, 2022 - 12:34 UTC
This incident affected: External Services.